EVPN – Native EVPN

ESI

ESI 主要用来标识CE, 相同CE使用一样的ESI.
EVPN技术为PE与某一CE的连接定义唯一的标识ESI(Ethernet Segment Identifier),连接同一CE的多个PE上的ESI值是相同,连接不同CE的ESI值不同。PE之间进行路由传播时,路由中会携带ESI值使PE间可以感知到连接同一CE的其他PE设备。

ESI共10字节, 1字节的type, 9字节vlaue。

配置案例:

RP/0/RSP0/CPU0:9001-2-PE4#show run evpn 
Thu Mar 11 07:36:12.984 UTC
evpn
 interface Bundle-Ether100
  ethernet-segment
   identifier type 0 11.11.11.11.11.11.11.11.11      <<<<<MHD 多个PE上要配置相同的ESI,RT也需要配置一样(RT-4 通告用来发现MHD的peer PE, RT用来限制导入)
   bgp route-target 1111.1111.1111
  !
 !
!

EVPN BGP Route-Type

Route-type 2: MAC Advertisement

格式如下:

//COMMAND
#show l2vpn forwarding bridge-domain 100:300 mac-address location 0/0/CPU0 
#show evpn evi vpn-id 300 mac 
#show bgp l2vpn evpn rd 10.1.1.1:300 route-type 2
#show bgp l2vpn evpn rd  10.1.1.1:300 [2][0][48][0011.0100.0001][0]/104
#show l2route evpn mac all  detail 

RP/0/RSP0/CPU0:ASR9901-3-PE1#   show l2vpn forwarding bridge-domain 100:300 mac-address location 0/0/CPU0 
Thu Jun 25 13:30:57.226 GMT+8
 To Resynchronize MAC table from the Network Processors, use the command...
    l2vpn resynchronize forwarding mac-address-table location <r/s/i>

Mac Address    Type    Learned from/Filtered on    LC learned Resync Age/Last Change Mapped to       
-------------- ------- --------------------------- ---------- ---------------------- --------------  
0012.0100.0001 EVPN    BD id: 0                    N/A        N/A                    N/A             
0012.0100.0002 EVPN    BD id: 0                    N/A        N/A                    N/A             
0012.0100.0003 EVPN    BD id: 0                    N/A        N/A                    N/A             
0012.0100.0004 EVPN    BD id: 0                    N/A        N/A                    N/A             
0012.0100.0005 EVPN    BD id: 0                    N/A        N/A                    N/A             
0012.0100.0006 EVPN    BD id: 0                    N/A        N/A                    N/A             
0012.0100.0007 EVPN    BD id: 0                    N/A        N/A                    N/A             
0012.0100.0008 EVPN    BD id: 0                    N/A        N/A                    N/A             
0012.0100.0009 EVPN    BD id: 0                    N/A        N/A                    N/A             
0012.0100.000a EVPN    BD id: 0                    N/A        N/A                    N/A             
0011.0100.0001 dynamic BE100.33                    N/A        25 Jun 13:28:27        N/A             
0011.0100.0002 dynamic BE100.33                    N/A        25 Jun 13:28:27        N/A             
0011.0100.0003 dynamic BE100.33                    N/A        25 Jun 13:28:27        N/A             
0011.0100.0004 dynamic BE100.33                    N/A        25 Jun 13:27:57        N/A             
0011.0100.0005 dynamic BE100.33                    N/A        25 Jun 13:28:27        N/A             
0011.0100.0006 dynamic BE100.33                    N/A        25 Jun 13:28:27        N/A             
0011.0100.0007 dynamic BE100.33                    N/A        25 Jun 13:28:27        N/A             
0011.0100.0008 dynamic BE100.33                    N/A        25 Jun 13:28:27        N/A             
0011.0100.0009 dynamic BE100.33                    N/A        25 Jun 13:28:27        N/A             
0011.0100.000a dynamic BE100.33                    N/A        25 Jun 13:28:27        N/A             
005f.8603.6401 dynamic BE100.33                    N/A        25 Jun 13:28:27        N/A             
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#show evpn evi vpn-id 300 mac 
Thu Jun 25 13:31:22.199 GMT+8

VPN-ID     Encap  MAC address    IP address                               Nexthop                                 Label   
---------- ------ -------------- ---------------------------------------- --------------------------------------- --------
300        MPLS   0011.0100.0001 ::                                       Bundle-Ether100.33                      24000   
300        MPLS   0011.0100.0002 ::                                       Bundle-Ether100.33                      24000   
300        MPLS   0011.0100.0003 ::                                       Bundle-Ether100.33                      24000   
300        MPLS   0011.0100.0004 ::                                       Bundle-Ether100.33                      24000   
300        MPLS   0011.0100.0005 ::                                       Bundle-Ether100.33                      24000   
300        MPLS   0011.0100.0006 ::                                       Bundle-Ether100.33                      24000   
300        MPLS   0011.0100.0007 ::                                       Bundle-Ether100.33                      24000   
300        MPLS   0011.0100.0008 ::                                       Bundle-Ether100.33                      24000   
300        MPLS   0011.0100.0009 ::                                       Bundle-Ether100.33                      24000   
300        MPLS   0011.0100.000a ::                                       Bundle-Ether100.33                      24000   
300        MPLS   0012.0100.0001 ::                                       10.1.3.3                                24001   
300        MPLS   0012.0100.0001 ::                                       10.1.4.4                                24007   
300        MPLS   0012.0100.0002 ::                                       10.1.3.3                                24001   
300        MPLS   0012.0100.0002 ::                                       10.1.4.4                                24007   
300        MPLS   0012.0100.0003 ::                                       10.1.3.3                                24001   
300        MPLS   0012.0100.0003 ::                                       10.1.4.4                                24007   
300        MPLS   0012.0100.0004 ::                                       10.1.3.3                                24001   
300        MPLS   0012.0100.0004 ::                                       10.1.4.4                                24007   
300        MPLS   0012.0100.0005 ::                                       10.1.3.3                                24001   
300        MPLS   0012.0100.0005 ::                                       10.1.4.4                                24007   
300        MPLS   0012.0100.0006 ::                                       10.1.3.3                                24001   
300        MPLS   0012.0100.0006 ::                                       10.1.4.4                                24007   
300        MPLS   0012.0100.0007 ::                                       10.1.3.3                                24001   
300        MPLS   0012.0100.0007 ::                                       10.1.4.4                                24007   
300        MPLS   0012.0100.0008 ::                                       10.1.3.3                                24001   
300        MPLS   0012.0100.0008 ::                                       10.1.4.4                                24007   
300        MPLS   0012.0100.0009 ::                                       10.1.3.3                                24001   
300        MPLS   0012.0100.0009 ::                                       10.1.4.4                                24007   
300        MPLS   0012.0100.000a ::                                       10.1.3.3                                24001   
300        MPLS   0012.0100.000a ::                                       10.1.4.4                                24007   
300        MPLS   005f.8603.6401 ::                                       Bundle-Ether100.33                      24000   
RP/0/RSP0/CPU0:ASR9901-3-PE1#show bgp l2vpn evpn rd 10.1.1.1:300 route-type 2
Thu Jun 25 13:32:02.731 GMT+8
BGP router identifier 10.1.1.1, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0   RD version: 0
BGP main routing table version 1156
BGP NSR Initial initsync version 1 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 10.1.1.1:300 (default for vrf 300)
*> [2][0][48][0011.0100.0001][0]/104
                      0.0.0.0                                0 i
*> [2][0][48][0011.0100.0002][0]/104
                      0.0.0.0                                0 i
*> [2][0][48][0011.0100.0003][0]/104
                      0.0.0.0                                0 i
*> [2][0][48][0011.0100.0004][0]/104
                      0.0.0.0                                0 i
*> [2][0][48][0011.0100.0005][0]/104
                      0.0.0.0                                0 i
*> [2][0][48][0011.0100.0006][0]/104
                      0.0.0.0                                0 i
*> [2][0][48][0011.0100.0007][0]/104
                      0.0.0.0                                0 i
*> [2][0][48][0011.0100.0008][0]/104
                      0.0.0.0                                0 i
*> [2][0][48][0011.0100.0009][0]/104
                      0.0.0.0                                0 i
*> [2][0][48][0011.0100.000a][0]/104
                      0.0.0.0                                0 i
*>i[2][0][48][0012.0100.0001][0]/104
                      10.1.3.3                      100      0 i
* i                   10.1.4.4                      100      0 i
*>i[2][0][48][0012.0100.0002][0]/104
                      10.1.3.3                      100      0 i
* i                   10.1.4.4                      100      0 i
*>i[2][0][48][0012.0100.0003][0]/104
                      10.1.3.3                      100      0 i
* i                   10.1.4.4                      100      0 i
*>i[2][0][48][0012.0100.0004][0]/104
                      10.1.3.3                      100      0 i
* i                   10.1.4.4                      100      0 i
*>i[2][0][48][0012.0100.0005][0]/104
                      10.1.3.3                      100      0 i
* i                   10.1.4.4                      100      0 i
*>i[2][0][48][0012.0100.0006][0]/104
                      10.1.3.3                      100      0 i
* i                   10.1.4.4                      100      0 i
*>i[2][0][48][0012.0100.0007][0]/104
                      10.1.3.3                      100      0 i
* i                   10.1.4.4                      100      0 i
*>i[2][0][48][0012.0100.0008][0]/104
                      10.1.3.3                      100      0 i
* i                   10.1.4.4                      100      0 i
*>i[2][0][48][0012.0100.0009][0]/104
                      10.1.3.3                      100      0 i
* i                   10.1.4.4                      100      0 i
*>i[2][0][48][0012.0100.000a][0]/104
                      10.1.3.3                      100      0 i
* i                   10.1.4.4                      100      0 i
*> [2][0][48][005f.8603.6401][0]/104
                      0.0.0.0                                0 i

Processed 21 prefixes, 31 paths
RP/0/RSP0/CPU0:ASR9901-3-PE1# 
RP/0/RSP0/CPU0:ASR9901-3-PE1#show bgp l2vpn evpn rd  10.1.1.1:300 [2][0][48][0011.0100.0001][0]/104
Thu Jun 25 13:32:56.482 GMT+8
BGP routing table entry for [2][0][48][0011.0100.0001][0]/104, Route Distinguisher: 10.1.1.1:300
Versions:
  Process           bRIB/RIB  SendTblVer
  Speaker               1097        1097
    Local Label: 24000
Last Modified: Jun 25 06:30:25.832 for 07:02:31
Paths: (1 available, best #1)
  Advertised to update-groups (with more than one peer):
    0.2 
  Path #1: Received by speaker 0
  Advertised to update-groups (with more than one peer):
    0.2 
  Local
    0.0.0.0 from 0.0.0.0 (10.1.1.1)
      Origin IGP, localpref 100, valid, redistributed, best, group-best, import-candidate, rib-install
      Received Path ID 0, Local Path ID 1, version 1097
      Extended community: SoO:10.1.1.1:300 RT:65001:300 
      EVPN ESI: 0022.2222.2222.2222.2222
RP/0/RSP0/CPU0:ASR9901-3-PE1#
Route-type 3: Inclusive Multicast Advertisement

格式如下:

//COMMAND

show evpn evi vpn-id 300 inclusive-multicast detail 
show bgp l2vpn evpn rd 10.1.1.1:300 route-type 3 
show bgp l2vpn evpn rd 10.1.1.1:300 [3][0][32][10.1.1.1]/80 detail 
show l2vpn forwarding bridge-domain evpn inclusive-multicast detail location 0/0/CPU0


RP/0/RSP0/CPU0:ASR9901-3-PE1#show evpn evi vpn-id 300 inclusive-multicast detail 
Thu Jun 25 13:50:32.307 GMT+8

VPN-ID     Encap  EtherTag   Originating IP                          
---------- ------ ---------- ----------------------------------------
300        MPLS   0          10.1.1.1                                
    TEPid  : 0xffffffff
    Nexthop: ::
    Label  : 24001
    Source : Local
300        MPLS   0          10.1.3.3                                
    TEPid  : 0xffffffff
    Nexthop: 10.1.3.3
    Label  : 24002
    Source : Remote
300        MPLS   0          10.1.4.4                                
    TEPid  : 0xffffffff
    Nexthop: 10.1.4.4
    Label  : 24008
    Source : Remote
RP/0/RSP0/CPU0:ASR9901-3-PE1# 
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#show bgp l2vpn evpn r
rd          regexp  rnh  route-policy
route-type  rt-set  
RP/0/RSP0/CPU0:ASR9901-3-PE1#show bgp l2vpn evpn rd 10.1.1.1:300 route-type 3
Thu Jun 25 13:50:54.613 GMT+8
BGP router identifier 10.1.1.1, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0   RD version: 0
BGP main routing table version 1156
BGP NSR Initial initsync version 1 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 10.1.1.1:300 (default for vrf 300)
*> [3][0][32][10.1.1.1]/80
                      0.0.0.0                                0 i
*>i[3][0][32][10.1.3.3]/80
                      10.1.3.3                      100      0 i
*>i[3][0][32][10.1.4.4]/80
                      10.1.4.4                      100      0 i

Processed 3 prefixes, 3 paths
RP/0/RSP0/CPU0:ASR9901-3-PE1#show bgp l2vpn evpn rd 10.1.1.1:300 [3][0][32][10.1.1.1]/80 detail 
Thu Jun 25 13:51:21.093 GMT+8
BGP routing table entry for [3][0][32][10.1.1.1]/80, Route Distinguisher: 10.1.1.1:300
Versions:
  Process           bRIB/RIB  SendTblVer
  Speaker                  2           2
    Flags: 0x00040001+0x00000000; 
Last Modified: Jun 22 08:10:34.832 for 3d05h
Paths: (1 available, best #1)
  Advertised to update-groups (with more than one peer):
    0.2 
  Path #1: Received by speaker 0
  Flags: 0x402000000504000b, import: 0x00
  Advertised to update-groups (with more than one peer):
    0.2 
  Local
    0.0.0.0 from 0.0.0.0 (10.1.1.1)
      Origin IGP, localpref 100, valid, redistributed, best, group-best, import-candidate
      Received Path ID 0, Local Path ID 1, version 2
      Extended community: RT:65001:300 
      PMSI: flags 0x00, type 6, label 24001, ID 0x0a010101
RP/0/RSP0/CPU0:ASR9901-3-PE1#  
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#show l2vpn forwarding bridge-domain 100:300 evpn inclusive-multicast de
ldebug  detail  
RP/0/RSP0/CPU0:ASR9901-3-PE1#show l2vpn forwarding bridge-domain 100:300 evpn inclusive-multicast detail location 0/0/CPU0 
Thu Jun 25 13:51:57.462 GMT+8
Bridge-Domain Name               BD-ID  XCID       TEP-id     Next Hop        Label/VNI  Encap    Status 
-------------------------------- ------ ---------- ---------- --------------- ---------- -------- -------
100:300                          0      0x80000003
   Status: bound
   Flags: default multicast replication
                                                   0xffffffff 10.1.3.3        24002      10       bound    <<<<<<<
                                                   0xffffffff 10.1.4.4        24008      10       bound    <<<<<<<
Route-type 4: DF Election
//Command:

show evpn ethernet-segment interface Bundle-Ether100 detail 
show bgp l2vpn evpn rd 10.1.3.3:0 route-type ethernet-segment 
show bgp l2vpn evpn rd 10.1.3.3:0 [4][0011.1111.1111.1111.1111][32][10.1.3.3]/128 detail
show bgp rt l2vpn evpn 
show evpn ethernet-segment interface Bundle-Ether100 detail 
show evpn ethernet-segment interface Bundle-Ether100 carving detail 

RP/0/RSP0/CPU0:9901-1-PE3#show evpn ethernet-segment interface bundle-Ether 100 detail 
Thu Nov 26 02:05:25.194 HKT
Legend:
  B   - No Forwarders EVPN-enabled,
  C   - Backbone Source MAC missing (PBB-EVPN),
  RT  - ES-Import Route Target missing,
  E   - ESI missing,
  H   - Interface handle missing,
  I   - Name (Interface or Virtual Access) missing,
  M   - Interface in Down state,
  O   - BGP End of Download missing,
  P   - Interface already Access Protected,
  Pf  - Interface forced single-homed,
  R   - BGP RID not received,
  S   - Interface in redundancy standby state,
  X   - ESI-extracted MAC Conflict
  SHG - No local split-horizon-group label allocated

Ethernet Segment Id      Interface                          Nexthops            
------------------------ ---------------------------------- --------------------
0011.1111.1111.1111.1111 BE100                              10.1.3.3
                                                            10.1.4.4
  ES to BGP Gates   : Ready
  ES to L2FIB Gates : P
  Main port         :
     Interface name : Bundle-Ether100
     Interface MAC  : f4db.e68d.352b
     IfHandle       : 0x00000720
     State          : Up
     Redundancy     : Not Defined
  ESI type          : 0
     Value          : 11.1111.1111.1111.1111
  ES Import RT      : 1111.1111.1111 (Local)
  Source MAC        : 0000.0000.0000 (N/A)
  Topology          :
     Operational    : MH, Single-flow-active
     Configured     : All-active (AApF) (default)
  Service Carving   : Auto-selection
     Multicast      : Disabled
  Peering Details   :
     10.1.3.3 [MOD:P:00]
     10.1.4.4 [MOD:P:00]

  Service Carving Results:
     Forwarders     : 2
     Elected        : 0
     Not Elected    : 0
  EVPN-VPWS Service Carving Results:
     Primary        : 0
     Backup         : 0
     Non-DF         : 0
  MAC Flushing mode : STP-TCN
  Peering timer     : 3 sec [not running]
  Recovery timer    : 30 sec [not running]
  Carving timer     : 0 sec [not running]
  Local SHG label   : 24005
  Remote SHG labels : 1
              24009 : nexthop 10.1.4.4
  Access signal mode: Bundle OOS (Default)

RP/0/RSP0/CPU0:9901-1-PE3# show bgp l2vpn evpn rd 10.1.3.3:0 route-type ?        
  <1-8>              Route type value
  ethernet-ad        Display EVPN Ethernet Advertisement routes
  ethernet-segment   Display EVPN Ethernet Segment routes
  igmp-join-synch    Display EVPN MCAST Join synch routes
  igmp-leave-synch   Display EVPN MCAST Leave synch routes
  inclusive-mcast    Display EVPN Inclusive Multicast routes
  ip-advertisement   Display EVPN IP Advertisement routes
  mac-advertisement  Display EVPN MAC Advertisement routes
RP/0/RSP0/CPU0:9901-1-PE3# show bgp l2vpn evpn rd 10.1.3.3:0 route-type ethernet-segment 
Thu Nov 26 02:06:16.996 HKT
BGP router identifier 10.1.3.3, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0   RD version: 0
BGP main routing table version 427
BGP NSR Initial initsync version 1 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 10.1.3.3:0 (default for vrf ES:GLOBAL)
*> [4][0011.1111.1111.1111.1111][32][10.1.3.3]/128
                      0.0.0.0                                0 i
*>i[4][0011.1111.1111.1111.1111][32][10.1.4.4]/128
                      10.1.4.4                      100      0 i

Processed 2 prefixes, 2 paths
RP/0/RSP0/CPU0:9901-1-PE3# show bgp l2vpn evpn rd 10.1.3.3:0 [4][0011.1111.1111.1111.1111][32][10.1.3.3]/128 detail 
Thu Nov 26 02:06:36.320 HKT
BGP routing table entry for [4][0011.1111.1111.1111.1111][32][10.1.3.3]/128, Route Distinguisher: 10.1.3.3:0
Versions:
  Process           bRIB/RIB  SendTblVer
  Speaker                299         299
    Flags: 0x00040001+0x00000000; 
Last Modified: Nov 25 18:09:33.833 for 07:57:03
Paths: (1 available, best #1)
  Advertised to update-groups (with more than one peer):
    0.2 
  Path #1: Received by speaker 0
  Flags: 0x400002000504000b, import: 0x00, EVPN: 0x0
  Advertised to update-groups (with more than one peer):
    0.2 
  Local
    0.0.0.0 from 0.0.0.0 (10.1.3.3), if-handle 0x00000000
      Origin IGP, localpref 100, valid, redistributed, best, group-best, import-candidate, rib-install
      Received Path ID 0, Local Path ID 1, version 299
      Extended community: EVPN ES Import:1111.1111.1111 DF Election:0:0x0000:0 
RP/0/RSP0/CPU0:9901-1-PE3#show bgp rt
 rt  rt-set  
RP/0/RSP0/CPU0:9901-1-PE3#show bgp rt l2vpn evpn 
Thu Nov 26 02:07:02.324 HKT
EXTCOMM         IMP/EXP
RT:65001:300             1 / 1
RT:65001:400             1 / 1
EVPN ES Import:1111.1111.1111            1 / 0
Processed 3 entries
RP/0/RSP0/CPU0:9901-1-PE3#
RP/0/RSP0/CPU0:9901-1-PE3#
RP/0/RSP0/CPU0:9901-1-PE3#
RP/0/RSP0/CPU0:9901-1-PE3#
RP/0/RSP0/CPU0:9901-1-PE3#show evpn ethernet-segment interface bundle-Ether 100 carving detail 
Thu Nov 26 02:07:46.647 HKT
Legend:
  B   - No Forwarders EVPN-enabled,
  C   - Backbone Source MAC missing (PBB-EVPN),
  RT  - ES-Import Route Target missing,
  E   - ESI missing,
  H   - Interface handle missing,
  I   - Name (Interface or Virtual Access) missing,
  M   - Interface in Down state,
  O   - BGP End of Download missing,
  P   - Interface already Access Protected,
  Pf  - Interface forced single-homed,
  R   - BGP RID not received,
  S   - Interface in redundancy standby state,
  X   - ESI-extracted MAC Conflict
  SHG - No local split-horizon-group label allocated

Ethernet Segment Id      Interface                          Nexthops            
------------------------ ---------------------------------- --------------------
0011.1111.1111.1111.1111 BE100                              10.1.3.3
                                                            10.1.4.4
  ES to BGP Gates   : Ready
  ES to L2FIB Gates : P
  Main port         :
     Interface name : Bundle-Ether100
     Interface MAC  : f4db.e68d.352b
     IfHandle       : 0x00000720
     State          : Up
     Redundancy     : Not Defined
  ESI type          : 0
     Value          : 11.1111.1111.1111.1111
  ES Import RT      : 1111.1111.1111 (Local)
  Source MAC        : 0000.0000.0000 (N/A)
  Topology          :
     Operational    : MH, Single-flow-active
     Configured     : All-active (AApF) (default)
  Service Carving   : Auto-selection
     Multicast      : Disabled
  Peering Details   :
     10.1.3.3 [MOD:P:00]
     10.1.4.4 [MOD:P:00]

  Service Carving Results:
     Forwarders     : 2
     Elected        : 0
     Not Elected    : 0
  EVPN-VPWS Service Carving Results:
     Primary        : 0
     Backup         : 0
     Non-DF         : 0
  MAC Flushing mode : STP-TCN
  Peering timer     : 3 sec [not running]
  Recovery timer    : 30 sec [not running]
  Carving timer     : 0 sec [not running]
  Local SHG label   : 24005
  Remote SHG labels : 1
              24009 : nexthop 10.1.4.4
  Access signal mode: Bundle OOS (Default)
Route-type 1 ES-EAD ( Split-Horizon )

PE4 收到从CE过来的广播流量会复制两份, 一份发给PE1 封装为 SR Label / BUM Label ; 一份给PE3 封装为 SR Label / BUM Label / SHG label

//COMMAND

show evpn ethernet-segment interface Bundle-Ether100 detail 
show bgp l2vpn evpn route-type ethernet-ad 
show bgp l2vpn evpn rd 10.1.3.3:0 [1][10.1.3.3:1][0011.1111.1111.1111.1111][4294967295]/184 detail 
show bgp l2vpn evpn rd 10.1.3.3:300 route-type 1 

RP/0/RSP0/CPU0:9901-1-PE3#show evpn ethernet-segment interface bundle-Ether 100 detail 
Thu Nov 26 15:34:46.741 HKT
Legend:
  B   - No Forwarders EVPN-enabled,
  C   - Backbone Source MAC missing (PBB-EVPN),
  RT  - ES-Import Route Target missing,
  E   - ESI missing,
  H   - Interface handle missing,
  I   - Name (Interface or Virtual Access) missing,
  M   - Interface in Down state,
  O   - BGP End of Download missing,
  P   - Interface already Access Protected,
  Pf  - Interface forced single-homed,
  R   - BGP RID not received,
  S   - Interface in redundancy standby state,
  X   - ESI-extracted MAC Conflict
  SHG - No local split-horizon-group label allocated

Ethernet Segment Id      Interface                          Nexthops            
------------------------ ---------------------------------- --------------------
0011.1111.1111.1111.1111 BE100                              10.1.3.3
                                                            10.1.4.4
  ES to BGP Gates   : Ready
  ES to L2FIB Gates : P
  Main port         :
     Interface name : Bundle-Ether100
     Interface MAC  : f4db.e68d.352b
     IfHandle       : 0x00000720
     State          : Up
     Redundancy     : Not Defined
  ESI type          : 0
     Value          : 11.1111.1111.1111.1111
  ES Import RT      : 1111.1111.1111 (Local)
  Source MAC        : 0000.0000.0000 (N/A)
  Topology          :
     Operational    : MH, Single-flow-active
     Configured     : All-active (AApF) (default)
  Service Carving   : Auto-selection
     Multicast      : Disabled
  Peering Details   :
     10.1.3.3 [MOD:P:00]
     10.1.4.4 [MOD:P:00]

  Service Carving Results:
     Forwarders     : 2
     Elected        : 0
     Not Elected    : 0
  EVPN-VPWS Service Carving Results:
     Primary        : 0
     Backup         : 0
     Non-DF         : 0
  MAC Flushing mode : STP-TCN
  Peering timer     : 3 sec [not running]
  Recovery timer    : 30 sec [not running]
  Carving timer     : 0 sec [not running]
  Local SHG label   : 24005
  Remote SHG labels : 1
              24009 : nexthop 10.1.4.4
  Access signal mode: Bundle OOS (Default)

RP/0/RSP0/CPU0:9901-1-PE3#  
RP/0/RSP0/CPU0:9901-1-PE3#
RP/0/RSP0/CPU0:9901-1-PE3#
RP/0/RSP0/CPU0:9901-1-PE3#show bgp l2vpn evpn  route-type ethernet-ad 
Thu Nov 26 15:35:04.527 HKT
BGP router identifier 10.1.3.3, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0   RD version: 0
BGP main routing table version 427
BGP NSR Initial initsync version 1 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 10.1.1.1:1
*>i[1][10.1.1.1:1][0022.2222.2222.2222.2222][4294967295]/184
                      10.1.1.1                      100      0 i
Route Distinguisher: 10.1.1.1:300
*>i[1][0022.2222.2222.2222.2222][0]/120
                      10.1.1.1                      100      0 i
Route Distinguisher: 10.1.1.1:400
*>i[1][0022.2222.2222.2222.2222][0]/120
                      10.1.1.1                      100      0 i
Route Distinguisher: 10.1.3.3:0 (default for vrf ES:GLOBAL)
*> [1][10.1.3.3:1][0011.1111.1111.1111.1111][4294967295]/184
                      0.0.0.0                                0 i
Route Distinguisher: 10.1.3.3:300 (default for vrf 300)
*> [1][0011.1111.1111.1111.1111][0]/120
                      0.0.0.0                                0 i
* i                   10.1.4.4                      100      0 i
*>i[1][0011.1111.1111.1111.1111][4294967295]/120
                      10.1.4.4                      100      0 i
*>i[1][0022.2222.2222.2222.2222][0]/120
                      10.1.1.1                      100      0 i
*>i[1][0022.2222.2222.2222.2222][4294967295]/120
                      10.1.1.1                      100      0 i
Route Distinguisher: 10.1.3.3:400 (default for vrf 400)
*> [1][0011.1111.1111.1111.1111][0]/120
                      0.0.0.0                                0 i
* i                   10.1.4.4                      100      0 i
*>i[1][0011.1111.1111.1111.1111][4294967295]/120
                      10.1.4.4                      100      0 i
*>i[1][0022.2222.2222.2222.2222][0]/120
                      10.1.1.1                      100      0 i
*>i[1][0022.2222.2222.2222.2222][4294967295]/120
                      10.1.1.1                      100      0 i
Route Distinguisher: 10.1.4.4:1
*>i[1][10.1.4.4:1][0011.1111.1111.1111.1111][4294967295]/184
                      10.1.4.4                      100      0 i
Route Distinguisher: 10.1.4.4:300
*>i[1][0011.1111.1111.1111.1111][0]/120
                      10.1.4.4                      100      0 i
Route Distinguisher: 10.1.4.4:400
*>i[1][0011.1111.1111.1111.1111][0]/120
                      10.1.4.4                      100      0 i

Processed 15 prefixes, 17 paths
RP/0/RSP0/CPU0:9901-1-PE3#
RP/0/RSP0/CPU0:9901-1-PE3#
RP/0/RSP0/CPU0:9901-1-PE3#show bgp l2vpn evpn rd 10.1.3.3:0 [1][10.1.3.3:1][0011.1111.1111.1111.1111][4294967295]/184 detail 
Thu Nov 26 15:36:24.408 HKT
BGP routing table entry for [1][10.1.3.3:1][0011.1111.1111.1111.1111][4294967295]/184, Route Distinguisher: 10.1.3.3:0
Versions:
  Process           bRIB/RIB  SendTblVer
  Speaker                304         304
    Local Label: 0 (no rewrite); 
    Flags: 0x00040001+0x00000000; 
Last Modified: Nov 25 18:09:36.833 for 21:26:48
Paths: (1 available, best #1)
  Advertised to update-groups (with more than one peer):
    0.2 
  Path #1: Received by speaker 0
  Flags: 0x402002000504000b, import: 0x00, EVPN: 0x0
  Advertised to update-groups (with more than one peer):
    0.2 
  Local
    0.0.0.0 from 0.0.0.0 (10.1.3.3), if-handle 0x00000000
      Origin IGP, localpref 100, valid, redistributed, best, group-best, import-candidate, rib-install
      Received Path ID 0, Local Path ID 1, version 304
      Extended community: EVPN ESI Label:0x02:24005 RT:65001:300 RT:65001:400 
RP/0/RSP0/CPU0:9901-1-PE3#
RP/0/RSP0/CPU0:9901-1-PE3#show bgp l2vpn evpn rd 10.1.3.3:300 route-type 1
Thu Nov 26 15:37:29.610 HKT
BGP router identifier 10.1.3.3, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0   RD version: 0
BGP main routing table version 427
BGP NSR Initial initsync version 1 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 10.1.3.3:300 (default for vrf 300)
*> [1][0011.1111.1111.1111.1111][0]/120
                      0.0.0.0                                0 i
* i                   10.1.4.4                      100      0 i
*>i[1][0011.1111.1111.1111.1111][4294967295]/120
                      10.1.4.4                      100      0 i
*>i[1][0022.2222.2222.2222.2222][0]/120
                      10.1.1.1                      100      0 i
*>i[1][0022.2222.2222.2222.2222][4294967295]/120
                      10.1.1.1                      100      0 i

Processed 4 prefixes, 5 paths
Route-type 1 EVI-EAD(Aliasing)

生么是aliasing:

Command:

show bgp l2vpn evpn rd 10.1.1.1:300 route-type 1 
show bgp l2vpn evpn rd 10.1.1.1:300 [1][0011.1111.1111.1111.1111][0]/120 detail 
show evpn internal-label vpn-id 300 detail 
show cli history detail 


RP/0/RSP0/CPU0:ASR9901-3-PE1#show bgp l2vpn evpn rd 10.1.1.1:300 route-type 1
Fri Jun 26 03:57:53.556 GMT+8
BGP router identifier 10.1.1.1, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0   RD version: 0
BGP main routing table version 1156
BGP NSR Initial initsync version 1 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 10.1.1.1:300 (default for vrf 300)
*>i[1][0011.1111.1111.1111.1111][0]/120
                      10.1.3.3                      100      0 i
* i                   10.1.4.4                      100      0 i
*>i[1][0011.1111.1111.1111.1111][4294967295]/120
                      10.1.3.3                      100      0 i
* i                   10.1.4.4                      100      0 i
*> [1][0022.2222.2222.2222.2222][0]/120
                      0.0.0.0                                0 i

Processed 3 prefixes, 5 paths
RP/0/RSP0/CPU0:ASR9901-3-PE1# 
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#show bgp l2vpn evpn rd 10.1.1.1:300 [1][0011.1111.1111.1111.1111][0]/120 detail 
Fri Jun 26 03:58:28.256 GMT+8
BGP routing table entry for [1][0011.1111.1111.1111.1111][0]/120, Route Distinguisher: 10.1.1.1:300
Versions:
  Process           bRIB/RIB  SendTblVer
  Speaker               1091        1091
    Flags: 0x00001001+0x00010000; 
Last Modified: Jun 25 06:29:04.832 for 21:29:24
Paths: (2 available, best #1)
  Not advertised to any peer
  Path #1: Received by speaker 0
  Flags: 0x4000020005068005, import: 0x80
  Not advertised to any peer
  Local, (received & used)
    10.1.3.3 (metric 2) from 10.1.3.3 (10.1.3.3)
      Received Label 24001 
      Origin IGP, localpref 100, valid, internal, best, group-best, import-candidate, imported, rib-install
      Received Path ID 0, Local Path ID 1, version 1091
      Extended community: RT:65001:300 
      Source AFI: L2VPN EVPN, Source VRF: default, Source Route Distinguisher: 10.1.3.3:300
  Path #2: Received by speaker 0
  Flags: 0x4000020004028005, import: 0x80
  Not advertised to any peer
  Local, (received & used)
    10.1.4.4 (metric 2) from 10.1.4.4 (10.1.4.4)
      Received Label 24007 
      Origin IGP, localpref 100, valid, internal, import-candidate, imported, rib-install
      Received Path ID 0, Local Path ID 0, version 0
      Extended community: RT:65001:300 
      Source AFI: L2VPN EVPN, Source VRF: default, Source Route Distinguisher: 10.1.4.4:300
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#show evpn internal-label vpn-id 300 detail 
Fri Jun 26 03:59:07.981 GMT+8

VPN-ID     Encap  Ethernet Segment Id         EtherTag   Label   
---------- ------ --------------------------- --------   --------
300        MPLS   0011.1111.1111.1111.1111    0          24003   
   Multi-paths resolved: TRUE (Remote all-active) 
   Multi-paths Internal label: 24003
   Pathlists:
     MAC        10.1.3.3                                 24001          
                10.1.4.4                                 24007          
     EAD/ES     10.1.3.3                                 0              
                10.1.4.4                                 0              
     EAD/EVI    10.1.3.3                                 24001          
                10.1.4.4                                 24007          
   Summary pathlist:
     0xffffffff 10.1.3.3                                 24001          
     0xffffffff 10.1.4.4                                 24007          

配置

PE1
RP/0/RSP0/CPU0:ASR9901-3-PE1#show run l2vpn 
Fri Jun 26 05:24:34.678 GMT+8
l2vpn
 description elan
 bridge group 100
  bridge-domain 300
   description elan
   interface Bundle-Ether100.33
    split-horizon group
   !
   evi 300
   !
  !
  bridge-domain 400
   description elan
   interface Bundle-Ether100.44
    split-horizon group
   !
   evi 400
   !
  !
 !
!

RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#show run evpn 
Fri Jun 26 05:24:38.189 GMT+8
evpn
 evi 300
  bgp
   route-target import 65001:300
   route-target export 65001:300
  !
  advertise-mac
  !
 !
 evi 400
  bgp
   route-target import 65001:400
   route-target export 65001:400
  !
  advertise-mac
  !
 !
 interface Bundle-Ether100
  ethernet-segment
   identifier type 0 22.22.22.22.22.22.22.22.22
   bgp route-target 2222.2222.2222
  !
 !
!

RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#show run router bgp 
Fri Jun 26 05:24:46.108 GMT+8
router bgp 65001
 bgp router-id 10.1.1.1
 address-family l2vpn evpn
 !
 neighbor 10.1.3.3
  remote-as 65001
  update-source Loopback100
  address-family l2vpn evpn
   soft-reconfiguration inbound always
  !
 !
 neighbor 10.1.4.4
  remote-as 65001
  update-source Loopback100
  address-family l2vpn evpn
   soft-reconfiguration inbound always
  !
 !
!

RP/0/RSP0/CPU0:ASR9901-3-PE1#
RP/0/RSP0/CPU0:ASR9901-3-PE1#show run router isis 
Fri Jun 26 05:24:49.847 GMT+8
router isis xuxing
 is-type level-2-only
 net 49.0000.0000.0001.00
 address-family ipv4 unicast
  metric-style wide
  segment-routing mpls
 !
 interface Loopback100
  passive
  circuit-type level-2-only
  address-family ipv4 unicast
   prefix-sid absolute 16001
  !
 !
 interface GigabitEthernet0/0/0/0
  circuit-type level-2-only
  point-to-point
  address-family ipv4 unicast
   fast-reroute per-prefix
   fast-reroute per-prefix ti-lfa
   metric 1
  !
 !
!
RP/0/RSP0/CPU0:ASR9901-3-PE1#show run int bundle-ether 100*
Fri Jun 26 05:26:06.184 GMT+8
interface Bundle-Ether100
 lacp system mac 0100.0100.0100
 load-interval 30
!
interface Bundle-Ether100.33 l2transport
 encapsulation dot1q 33
 rewrite ingress tag pop 1 symmetric
!
interface Bundle-Ether100.44 l2transport
 encapsulation dot1q 44
 rewrite ingress tag pop 1 symmetric
!

PE3
RP/0/RSP0/CPU0:9901-1-PE3#show run l2vpn            
Thu Nov 26 17:32:50.916 HKT
l2vpn
 description elan
 bridge group 100
  bridge-domain 300
   description elan
   interface Bundle-Ether100.33
    split-horizon group
   !
   evi 300
   !
  !
  bridge-domain 400
   description elan
   interface Bundle-Ether100.44
    split-horizon group
   !
   evi 400
   !
  !
 !
!

RP/0/RSP0/CPU0:9901-1-PE3#show run evpn 
Thu Nov 26 17:32:53.898 HKT
evpn
 evi 300
  bgp
   route-target import 65001:300
   route-target export 65001:300
  !
  advertise-mac
  !
 !
 evi 400
  bgp
   route-target import 65001:400
   route-target export 65001:400
  !
  advertise-mac
  !
 !
 interface Bundle-Ether100
  ethernet-segment
   identifier type 0 11.11.11.11.11.11.11.11.11
   bgp route-target 1111.1111.1111
  !
 !
!

RP/0/RSP0/CPU0:9901-1-PE3#show run router bgp 
Thu Nov 26 17:32:57.445 HKT
router bgp 65001
 bgp router-id 10.1.3.3
 address-family l2vpn evpn
 !
 neighbor 10.1.1.1
  remote-as 65001
  update-source Loopback100
  address-family l2vpn evpn
  !
 !
 neighbor 10.1.4.4
  remote-as 65001
  update-source Loopback100
  address-family l2vpn evpn
  !
 !
!

RP/0/RSP0/CPU0:9901-1-PE3#show run router isis 
Thu Nov 26 17:33:03.779 HKT
router isis xuxing
 is-type level-2-only
 net 49.0000.0000.0003.00
 address-family ipv4 unicast
  metric-style wide
  segment-routing mpls
 !
 interface Loopback100
  passive
  circuit-type level-2-only
  address-family ipv4 unicast
   prefix-sid absolute 16003
  !
 !
 interface TenGigE0/0/0/30
  circuit-type level-2-only
  point-to-point
  address-family ipv4 unicast
   fast-reroute per-prefix
   fast-reroute per-prefix ti-lfa
   metric 1
  !
 !
!

RP/0/RSP0/CPU0:9901-1-PE3#
RP/0/RSP0/CPU0:9901-1-PE3#show run int bundle-ether 100*
Thu Nov 26 17:33:08.354 HKT
interface Bundle-Ether100
 lacp system mac 0100.0100.0100
 load-interval 30
!
interface Bundle-Ether100.33 l2transport
 encapsulation dot1q 33
 rewrite ingress tag pop 1 symmetric
!
interface Bundle-Ether100.44 l2transport
 encapsulation dot1q 44
 rewrite ingress tag pop 1 symmetric
PE4
RP/0/RSP0/CPU0:9001-2-PE4#show run l2vpn 
Fri Mar 12 00:06:17.309 UTC
l2vpn
 description elan
 bridge group 100
  bridge-domain 300
   description elan
   interface Bundle-Ether100.33
    split-horizon group
   !
   evi 300
   !
  !
  bridge-domain 400
   description elan
   interface Bundle-Ether100.44
    split-horizon group
   !
   evi 400
   !
  !
 !
!

RP/0/RSP0/CPU0:9001-2-PE4#show run evpn   
Fri Mar 12 00:06:22.449 UTC
evpn
 evi 300
  bgp
   route-target import 65001:300
   route-target export 65001:300
  !
  advertise-mac
  !
 !
 evi 400
  bgp
   route-target import 65001:400
   route-target export 65001:400
  !
  advertise-mac
  !
 !
 interface Bundle-Ether100
  ethernet-segment
   identifier type 0 11.11.11.11.11.11.11.11.11
   bgp route-target 1111.1111.1111
  !
 !
!

RP/0/RSP0/CPU0:9001-2-PE4#show run route rbg
                                    ^
% Invalid input detected at '^' marker.
RP/0/RSP0/CPU0:9001-2-PE4#show run router bgp 
Fri Mar 12 00:06:31.815 UTC
router bgp 65001
 bgp router-id 10.1.4.4
 address-family l2vpn evpn
 !
 neighbor 10.1.1.1
  remote-as 65001
  update-source Loopback100
  address-family l2vpn evpn
  !
 !
 neighbor 10.1.3.3
  remote-as 65001
  update-source Loopback100
  address-family l2vpn evpn
  !
 !
!

RP/0/RSP0/CPU0:9001-2-PE4#show run router isis 
Fri Mar 12 00:06:35.304 UTC
router isis xuxing
 is-type level-2-only
 net 49.0000.0000.0004.00
 address-family ipv4 unicast
  metric-style wide
  segment-routing mpls
 !
 interface Loopback100
  passive
  circuit-type level-2-only
  address-family ipv4 unicast
   prefix-sid absolute 16004
  !
 !
 interface TenGigE0/0/2/2
  circuit-type level-2-only
  point-to-point
  address-family ipv4 unicast
   fast-reroute per-prefix
   fast-reroute per-prefix ti-lfa
   metric 1
  !
 !
!

RP/0/RSP0/CPU0:9001-2-PE4#
RP/0/RSP0/CPU0:9001-2-PE4#
RP/0/RSP0/CPU0:9001-2-PE4#show run int bundle-ether 100*
Fri Mar 12 00:06:41.755 UTC
interface Bundle-Ether100
 lacp system mac 0100.0100.0100
 load-interval 30
!
interface Bundle-Ether100.33 l2transport
 encapsulation dot1q 33
 rewrite ingress tag pop 1 symmetric
!
interface Bundle-Ether100.44 l2transport
 encapsulation dot1q 44
 rewrite ingress tag pop 1 symmetric
!

           

No comments

Comments feed for this article

Reply

Your email address will not be published.