Step 1: 准备工作

VB脚本及Py脚本下载连接, 建议直接使用VB脚本,不用配置Python 环境.

VB脚本:ImportArbitraryDataFromFileToSecureCRTSessions(pre-v9.0,post-v7.2).vbs.txt

修改下后缀为vbs,打开脚本看下配置文件:

Read the rest of this entry »

Tags:

背景

工作用的Linux 虚机使用的是默认安装, 根只分了50G的空间, 用着用着就不够了,所以想着给扩个空间。

[root@localhost repository]#      df -h
Filesystem               Size  Used Avail Use% Mounted on
/dev/mapper/centos-root   50G   41G  9.4G  82% /
devtmpfs                  32G     0   32G   0% /dev
tmpfs                     32G     0   32G   0% /dev/shm
tmpfs                     32G  637M   31G   2% /run
tmpfs                     32G     0   32G   0% /sys/fs/cgroup
/dev/sda1               1014M  150M  865M  15% /boot
/dev/mapper/centos-home  441G   15G  427G   4% /home
overlay                   50G   41G  9.4G  82% /var/lib/docker/overlay2/398d2eeb78bef327ecaca5cd7de0087ce59f76a938e5ef5dbce91c2895a4b1aa/merged
overlay                   50G   41G  9.4G  82% /var/lib/docker/overlay2/0f05cdc7e42716c57997501e96310ca1769824b28ea91d2509502a35be589840/merged
overlay                   50G   41G  9.4G  82% /var/lib/docker/overlay2/5c10dbf435357bf50eecc148cb9a90d211384abca9fd9a5314de5fc62910c6f5/merged
overlay                   50G   41G  9.4G  82% /var/lib/docker/overlay2/a0fe47c9a9dca33b1fcfd35684aadc2037dc1398a23b2b09ebcad476636e0dab/merged
overlay                   50G   41G  9.4G  82% /var/lib/docker/overlay2/2eb88ff71135e7b9be851a22905aeded34038a1bdf06cf5d9c963a8378ecc923/merged
overlay                   50G   41G  9.4G  82% /var/lib/docker/overlay2/2013e4d4c128e0da65e969cfc432850615257874a81dd7bf73ade4bec75c4600/merged
overlay                   50G   41G  9.4G  82% /var/lib/docker/overlay2/912b49fbc5ead76d17e25059db4301cbcd0230e6be9063c5e17c6c9a1279da01/merged
tmpfs                    6.3G     0  6.3G   0% /run/user/0
overlay                   50G   41G  9.4G  82% /var/lib/docker/overlay2/11a70ceeddd9c3201fef095c4e65d61e24d1429a5c3e04b90310e1f3ebda6572/merged
Read the rest of this entry »

Tags:

This content is password protected. To view it please enter your password below:

BGP Flow Specification功能是一种用于防止DoS(Denial of Service)/DDoS(Distributed Denial of Service)攻击的方法,可以提高网络安全性和可用性。其实现方式为 BGP FS controller 通过BGP下发特定的规则给BGP FS client, BGP FS client收到后按照该规则对特定流进行redirect/remark/drop/rate limit。

Read the rest of this entry »

IKE(网络密钥交换协议)

IKE属于一种混合型协议,由Internet安全关联和密钥管理协议(ISAKMP)和两种密钥交换协议OAKLEY与SKEME组成。IKE创建在由ISAKMP定义的框架上,沿用了OAKLEY的密钥交换模式以及SKEME的共享和密钥更新技术,还定义了它自己的两种密钥交换方式:主模式和野蛮模式。

IKE协商两种SA:

  • IKE(ISAKMP) SA (Phase 1)
  • IPSEC SA(Phase 2)

IKE与IPSec的关系如下图所示,对等体之间建立一个IKE SA完成身份验证和密钥信息交换后,在IKE SA的保护下,根据配置的AH/ESP安全协议等参数协商出一对IPSec SA。此后,对等体间的数据将在IPSec隧道中加密传输。

IKE SA是一个双向的逻辑连接,两个对等体间只建立一个IKE SA。

IKE与IPSec的关系图
Read the rest of this entry »

GRE 简介

通用路由封装协议GRE(Generic Routing Encapsulation)可以对某些网络层协议(如IPX、ATM、IPv6、AppleTalk等)的数据报文进行封装(区别于IPsec, IPsec只能封装IP数据包),使这些被封装的数据报文能够在另一个网络层协议(如IPv4)中传输。

Read the rest of this entry »

DMVPN

DMVPN Phase 1:

R1配置:

R1_HUB#show run int tunnel 0 
Building configuration...

Current configuration : 219 bytes
!
interface Tunnel0
 ip address 172.168.123.1 255.255.255.0
 no ip redirects
 ip nhrp map multicast dynamic
 ip nhrp network-id 1
 tunnel source Ethernet0/0
 tunnel mode gre multipoint
end

R2 / R3 配置:

R2_spoke#show run int tunnel 0 
Building configuration...

Current configuration : 241 bytes
!
interface Tunnel0
 ip address 172.168.123.2 255.255.255.0
 ip nhrp map 172.168.123.1 10.1.14.1
 ip nhrp map multicast 10.1.14.1
 ip nhrp network-id 1
 ip nhrp nhs 172.168.123.1
 tunnel source Ethernet0/0
 tunnel destination 10.1.14.1
end
Read the rest of this entry »

BGP监控协议BGP Monitoring Protocol(BMP)能够对网络中的设备的BGP运行状态进行实时监控,BGP运行状态包括对等体关系的建立与解除、路由信息刷新等。

路由器只需要与BMP server建立一个TCP连接, 后续就可以发送BMP的数据包。

BMP的数据包包含以下7种类型:

  • Initiation消息:初始化消息,向监控服务器通告厂商信息、版本号等。
  • PU(Peer Up Notification)消息:向监控服务器上报与对等体BGP连接的建立。
  • RM(Route Monitoring)消息:路由监控消息,向监控服务器发送从对等体收到的所有路由,并随时向监控服务器上报路由的新增或撤销。
  • PD(Peer Down Notification)消息:向监控服务器上报与对等体BGP连接的中断。
  • SR(Stats Reports)消息:向监控服务器上报路由器运行状态的统计信息。
  • Termination消息:结束消息,向监控服务器通告关闭BMP会话的原因。
Read the rest of this entry »

« Older entries