EVPN-PBB EVPN

There are two types of traditional l2vpn, one is point-to-point (VPWS) and the other is point-to-multipoint(VPLS).
For VPLS, EVPN has a corresponding technology PBB-EVPN.
This topic, will intruduction a simple PBB-EVPN configuration.

Refer to the following route types,PBB-EVPN will use Type 2 and Type 3.

Topology

Core IGP

router isis 1
 is-type level-2-only
 net 49.0001.1391.5900.7248.00
 lsp-gen-interval maximum-wait 2000 initial-wait 100 secondary-wait 100
 address-family ipv4 unicast
  metric-style wide
 !
 interface Bundle-Ether1
  circuit-type level-2-only
  point-to-point
  address-family ipv4 unicast
   metric 5
  !
 !
 interface Loopback0
  passive
  circuit-type level-2-only
  address-family ipv4 unicast
  !
RP/0/RSP0/CPU0:ASR9001-B#show run mpls ldp 
Fri Oct 25 04:13:08.554 UTC
mpls ldp
 router-id 139.159.7.248
 address-family ipv4
 !
 interface Bundle-Ether1
  address-family ipv4
  !

PBB-EVPN

RP/0/RSP0/CPU0:ASR9001-B#show run router bgp 
Fri Oct 25 04:14:28.506 UTC
router bgp 65001
 bgp router-id 139.159.7.248

 address-family l2vpn evpn
 !
 neighbor 139.159.48.213
  remote-as 65001
  update-source Loopback0
  address-family l2vpn evpn
  !
RP/0/RSP0/CPU0:ASR9001-B#show run l2vpn 
Fri Oct 25 04:15:37.293 UTC
l2vpn
 bridge group 1
  bridge-domain PBB-core-10000
   pbb core
    evi 10000    <<<< need same with peer PE,Broadcast domain
    !
   !
  !
  bridge-domain PBB-edge-10000
   interface GigabitEthernet0/0/0/4.1
   !
   pbb edge i-sid 10000 core-bridge PBB-core-10000
   !
  !
RP/0/RSP0/CPU0:ASR9001-B# show ru int gi0/0/0/4.1    
Fri Oct 25 04:18:56.372 UTC
interface GigabitEthernet0/0/0/4.1 l2transport
 encapsulation dot1q 10
 rewrite ingress tag pop 1 symmetric
 mtu 9000
!

Check the route learn from Peer PE

RP/0/RSP0/CPU0:ASR9001-B#show bgp l2vpn evpn 
Fri Oct 25 04:19:25.234 UTC
BGP router identifier 139.159.7.248, local AS number 65001
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0   RD version: 0
BGP main routing table version 36
BGP NSR Initial initsync version 6 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 139.159.7.248:10000 (default for vrf PBB-core-10000)
*> [2][0][48][e4c7.225a.2fd0][0]/104    <<< Self BMAC
                      0.0.0.0                                0 i
*>i[2][0][48][e8ed.f344.050f][0]/104	<<< Remote PE BMAC 
                      139.159.48.213                100      0 i
*> [3][10000][32][139.159.7.248]/80     
                      0.0.0.0                                0 i
*>i[3][10000][32][139.159.48.213]/80
                      139.159.48.213                100      0 i
Route Distinguisher: 139.159.48.213:10000
*>i[2][0][48][e8ed.f344.050f][0]/104    <<< Remote PE BMAC  
                      139.159.48.213                100      0 i
*>i[3][10000][32][139.159.48.213]/80
                      139.159.48.213                100      0 i
RP/0/RSP0/CPU0:ASR9001-B#show l2vpn forwarding pbb backbone-source-mac detail location 0/rsp0/CPU0 
Fri Oct 25 04:25:04.241 UTC
Backbone Source MAC: e4c7.225a.2fd0    <<< Check BMAC
Chassis MAC        : e4c7.225a.2fd0
RP/0/RSP0/CPU0:ASR9001-B#
RP/0/RSP0/CPU0:ASR9001-B#show bgp l2vpn evpn rd 139.159.7.248:10000 [2][0][48][e8ed.f344.050f][0]/104 detail 
Fri Oct 25 04:27:54.322 UTC
BGP routing table entry for [2][0][48][e8ed.f344.050f][0]/104, Route Distinguisher: 139.159.7.248:10000
Versions:
  Process           bRIB/RIB  SendTblVer
  Speaker                 32          32
    Flags: 0x00001001+0x00000000; 
Last Modified: Oct 24 13:13:53.799 for 15:14:00
Paths: (1 available, best #1)
  Not advertised to any peer
  Path #1: Received by speaker 0
  Flags: 0x4000020005060005, import: 0x80
  Not advertised to any peer
  Local
    139.159.48.213 (metric 5) from 139.159.48.213 (139.159.48.213)
      Received Label 16008    <<<< Inner Label recieve
      Origin IGP, localpref 100, valid, internal, best, group-best, import-candidate, imported, rib-install
      Received Path ID 0, Local Path ID 1, version 32
      Extended community: RT:65001:10000 
      EVPN ESI: 0000.0000.0000.0000.0000
      Source AFI: L2VPN EVPN, Source VRF: default, Source Route Distinguisher: 139.159.48.213:10000
RP/0/RSP0/CPU0:ASR9001-B#
RP/0/RSP0/CPU0:ASR9001-B#show l2vpn forwarding bridge-domain 1:PBB-edge-10000 mac-address location 0/0/cPU0 
<<<< This command can check the MAC-address learning
           

No comments

Comments feed for this article

Reply

Your email address will not be published.