EVPN VPWS

首先放两张图,了解下EVPN VPWS。EVPN VPWS 会使用到Type1和Type 4两类路由,也分为Single-Home 和 Multi-home两种架构,这里记录下single-home的简单配置。

TOPO

Configuration

PE1:

RP/0/RP0/CPU0:ASR9922-B#show run int bundle-ether 800   
Thu Sep 10 08:48:09.262 UTC
interface Bundle-Ether800
 mtu 4860
 l2transport
 !
!

RP/0/RP0/CPU0:ASR9922-B#show run l2vpn xconnect group cisco-l2vpn-evpn-vpws
Thu Sep 10 08:48:29.189 UTC
l2vpn
 xconnect group cisco-l2vpn-evpn-vpws
  p2p vpws_64900
   interface Bundle-Ether800
   description vpws_64900 
   neighbor evpn evi 64900 target 819 source 198  <<< evi 需要一致, source标识本端AC,targe标识对端AC
   !
  !
 !
!

RP/0/RP0/CPU0:ASR9922-B#show run evpn 
Thu Sep 10 08:48:33.611 UTC
evpn
 evi 64900
  bgp
   rd 10.1.12.1:64900
   route-target import 9929:64900
   route-target export 9929:64900
  !
  description vpws_test
  control-word-disable
 !
!
RP/0/RP0/CPU0:ASR9922-B#show run router bgp 
Thu Sep 10 08:51:28.092 UTC
router bgp 38365
 bgp router-id 10.1.1.1
 !
 address-family l2vpn evpn
 !
 neighbor 10.1.2.2
  remote-as 38365
  update-source Loopback1000
  address-family l2vpn evpn
  !
 !

PE2

RP/0/RSP0/CPU0:ASR9006-L#show run int bundle-ether 800
Thu Sep 10 16:52:05.649 UTC
interface Bundle-Ether800
 mtu 4860
 l2transport
 !
!

RP/0/RSP0/CPU0:ASR9006-L#show run l2vpn xconnect group cisco-l2vpn-evpn-vpws
Thu Sep 10 16:52:09.704 UTC
l2vpn
 xconnect group cisco-l2vpn-evpn-vpws
  p2p vpws_64900
   interface Bundle-Ether800
   description vpws_64900 
   neighbor evpn evi 64900 target 198 source 819
   !
  !
 !
!

RP/0/RSP0/CPU0:ASR9006-L#show run evpn 
Thu Sep 10 16:52:13.473 UTC
evpn
 evi 64900
  bgp
   rd 10.1.12.2:64900
   route-target import 9929:64900
   route-target export 9929:64900
  !
  description vpws_test
  control-word-disable
 !
!
RP/0/RSP0/CPU0:ASR9006-L#show run router bgp 
Thu Sep 10 16:53:40.957 UTC
router bgp 38365
 bgp router-id 10.1.2.2
 address-family l2vpn evpn
 !
 neighbor 10.1.1.1
  remote-as 38365
  update-source Loopback1000
  address-family l2vpn evpn
  !
 !
!

底层起ISIS/LDP或者SR。

测试命令

#show l2vpn xconnnect <>
#show evpn evi ead
#show bgp l2vpn evpn route-type 1
RP/0/RP0/CPU0:ASR9922-B#show bgp l2vpn evpn summary 
Thu Sep 10 08:55:10.183 UTC
BGP router identifier 10.1.1.1, local AS number 38365
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0   RD version: 0
BGP main routing table version 55
BGP NSR Initial initsync version 1 (Reached)
BGP NSR/ISSU Sync-Group versions 55/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process       RcvTblVer   bRIB/RIB   LabelVer  ImportVer  SendTblVer  StandbyVer
Speaker              55         55         55         55          55          55

Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd
10.1.2.2          0 38365      21      20       55    0    0 00:16:51          1
RP/0/RP0/CPU0:ASR9922-B#show bgp l2vpn evpn 
Thu Sep 10 08:55:19.603 UTC
BGP router identifier 10.1.1.1, local AS number 38365
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0   RD version: 0
BGP main routing table version 55
BGP NSR Initial initsync version 1 (Reached)
BGP NSR/ISSU Sync-Group versions 55/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 10.1.12.1:64900 (default for vrf VPWS:64900)
*> [1][0000.0000.0000.0000.0000][198]/120
                      0.0.0.0                                0 i
*>i[1][0000.0000.0000.0000.0000][819]/120
                      10.1.2.2                      100      0 i
Route Distinguisher: 10.1.12.2:64900
*>i[1][0000.0000.0000.0000.0000][819]/120
                      10.1.2.2                      100      0 i

Processed 3 prefixes, 3 paths
RP/0/RP0/CPU0:ASR9922-B#show bgp l2vpn evpn rd 10.1.12.1:64900 [1][0000.0000.0000.0000.0000][198]/120 detail 
Thu Sep 10 08:55:30.735 UTC
BGP routing table entry for [1][0000.0000.0000.0000.0000][198]/120, Route Distinguisher: 10.1.12.1:64900
Versions:
  Process           bRIB/RIB  SendTblVer
  Speaker                 47          47
    Local Label: 24000 (no rewrite); 
    Flags: 0x00040001+0x00000000; 
Last Modified: Sep 10 08:14:15.832 for 00:41:14
Paths: (1 available, best #1)
  Advertised to peers (in unique update groups):
    10.1.2.2        
  Path #1: Received by speaker 0
  Flags: 0x402002000504000b, import: 0x00, EVPN: 0x0
  Advertised to peers (in unique update groups):
    10.1.2.2        
  Local
    0.0.0.0 from 0.0.0.0 (10.1.1.1), if-handle 0x00000260
      Origin IGP, localpref 100, valid, redistributed, best, group-best, import-candidate, rib-install
      Received Path ID 0, Local Path ID 1, version 47
      Extended community: EVPN L2 ATTRS:0x02:4846 RT:9929:64900 
RP/0/RP0/CPU0:ASR9922-B#
           

No comments

Comments feed for this article

Reply

Your email address will not be published.